Delayed Verifications In South Africa

Incident Report for Luno

Resolved

Update:

We are no longer seeing any delays with verifications for customer accounts.

Verifications should be working as normal.

We appreciate your understanding in matter
Posted Aug 04, 2025 - 09:53 UTC

Identified

We have identified an issue that is causing delays for profile verifications for new South African customers.

Customers may experience a delay when signing up for a new Luno account.

Unfortunately, this is due to a 3rd party provider issue and is not in our control.

We are working with them to resolve this as soon as possible
Posted Aug 04, 2025 - 07:23 UTC