Delayed Deposits in Nigeria
Incident Report for Luno
Resolved
The issue has been resolved and deposits via bank transfer are working as expected.

Thank you for your understanding and patience.
Posted Sep 03, 2024 - 15:49 UTC
Identified
Customers will experience delays with deposits via bank transfer. Vouchers are working as expected.

Unfortunately, this issue is with our payment provider, we are working closely with them to resolve this as soon as possible.

We appreciate your understanding and apologise for any inconvenience this may cause.
Posted Sep 03, 2024 - 14:34 UTC