Delayed deposits and withdrawals in Nigeria
Incident Report for Luno
Resolved
This has been resolved and deposits and withdrawals are being processed as normal.
Posted Oct 24, 2022 - 08:53 UTC
Update
We are currently experiencing an issue that may be causing temporary delays with deposit and withdrawal voucher redemption.
Posted Oct 22, 2022 - 18:28 UTC
Investigating
We are currently experiencing an issue that may be causing temporary delays with deposit voucher redemption, withdrawals remain unaffected.
Posted Oct 22, 2022 - 15:12 UTC