Delayed Ethereum sends
Incident Report for Luno
Resolved
This issue has been resolved, we are seeing no further issues with Ethereum sends being delayed.

We apologise for any inconvenience caused.
Posted May 11, 2023 - 18:39 UTC
Monitoring
A fix has been deployed for this and we are seeing no further issues with Ethereum sends at this time.
We will continue to monitor for any further issues.
Posted May 11, 2023 - 17:41 UTC
Investigating
We are currently investigating an issue which may be causing customers to experience delays when sending Ethereum.

We are working on this as a matter of priority and will provide updates as soon as they become available.
Posted May 11, 2023 - 16:41 UTC