Scheduled Maintenance Impacting Verification in Indonesia

Incident Report for Luno

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 05:59 UTC

Identified

Due to a scheduled maintenance, our verifications will be delayed in Indonesia.

Maintenance Schedule:

Start Date: Friday, July 25 2025
End Date: Saturday, July 26 2025
Time: 23:55 to 03:30 Jakarta Time
Duration: 3 hours 35 minutes

Our team will be closely monitoring the situation and will provide updates as the maintenance progresses.
Posted Jul 24, 2025 - 13:38 UTC