Slow account verification in Nigeria
Incident Report for Luno
Resolved
Account verification times have returned to normal.
Posted Sep 26, 2023 - 08:48 UTC
Update
While we have noted an increase in success rates, we're still seeing a small handful of customers have their account verified slower than we'd like. We'll monitor throughout the weekend and hopefully see some positive change early next week.

Thanks again for your continued patience.
Posted Sep 22, 2023 - 12:13 UTC
Monitoring
We're seeing slightly better performance, very few customers are now seeing delays compared to yesterday. We're continuing to monitor.
Posted Sep 21, 2023 - 07:54 UTC
Identified
Ongoing issues with identification lookups in Nigeria, account verification for Level 1 or above is taking longer than expected. Customers who started their account verification on or after 12:00 UTC on 19 September 2023 will see a longer turn around time to have their account verified.

We're working closely with our providers to ensure we can have account verification times return to normal.

Thanks for your patience.
Posted Sep 20, 2023 - 10:02 UTC