Delayed withdrawals in Malaysia
Incident Report for Luno
Resolved
All withdrawals are being processed as normal. Thanks for your patience.
Posted Sep 14, 2023 - 10:04 UTC
Monitoring
All withdrawals are being processed as normal, we're monitoring closely for any further errors.
Posted Sep 14, 2023 - 06:12 UTC
Identified
Upon further review, customers who requested withdrawals between 15:45 on 11 September 2023 and 02:21 on 12 September 2023 were affected. We apologise for any inconvenience. Our team is working to get these withdrawals processed as soon as possible.

All other deposits and withdrawals are being processed as scheduled.
Posted Sep 13, 2023 - 12:27 UTC
Investigating
We are currently investigating an issue that is causing some customers' MYR withdrawals to be delayed.

We are looking into this as a matter of priority and will provide updates as soon as they become available.
Posted Sep 12, 2023 - 02:08 UTC