Scheduled Maintenance Impacting Verification in Indonesia

Incident Report for Luno

Resolved

Maintenance has been completed, we thank you for your patience
Posted Apr 09, 2025 - 18:41 UTC

Identified

Due to a scheduled maintenance, our verifications in Indonesia will be delayed.

Maintenance Schedule:
Date: Wednesday, April 09, 2025
Time: 15:00 GMT to 19:00 GMT
Expected Downtime: Approximately 4 hours

Our team will be closely monitoring the situation and will provide updates as the maintenance progresses.
Posted Apr 09, 2025 - 15:00 UTC