Delayed account verification in Nigeria
Incident Report for Luno
Resolved
Account verification services are now fully functional and we are now able to verify new customers normally, without any delays.
Posted Aug 06, 2022 - 08:47 UTC
Investigating
We are experiencing delays with account verification for new customers in Nigeria. We are investigating this issue as a priority.

We apologise for any inconvenience and will provide an update as soon as possible.
Posted Aug 05, 2022 - 06:16 UTC