Unable to Buy via PayU in South Africa
Incident Report for
Luno
Resolved
Update:
Instant deposits via PayU is now available.
We appreciate your patience and understanding in this matter.
Posted
Nov
13
,
2024
-
10:15
UTC
Update
Update:
PayU is still temporarily unavailable.
Please use an alternative method available in the Buy/Deposit screens.
We appreciate your understanding in this matter.
Updates to follow.
Posted
Nov
08
,
2024
-
08:08
UTC
Identified
Customers in South Africa will temporarily be unable to buy crypto via PayU.
Please use an alternative method available in the Buy/Deposit screens.
Updates to follow
Posted
Nov
07
,
2024
-
09:39
UTC
×
Subscribe to Incident
Subscribe to updates for
Unable to Buy via PayU in South Africa
via . You'll receive .