Delayed sign ups due to Recaptcha's failing

Incident Report for Luno

Resolved

This issue is now resolved. Thank you for your patience.
Posted Feb 20, 2025 - 15:08 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 20, 2025 - 14:35 UTC

Update

We have implemented a fix and are currently monitoring it.
Posted Feb 20, 2025 - 14:35 UTC

Investigating

We're currently experiencing an issue with Recaptcha which is causing delays in new sign ups. We're actively investigating this issue and working on a fix. Updates to follow.
Posted Feb 20, 2025 - 11:23 UTC