Delayed Balance Updates
Incident Report for
Luno
Resolved
Update:
We are no longer seeing any delays with balance updates.
We appreciate your patience and understanding in this matter.
Posted
Oct
20
,
2025
-
07:02
UTC
Monitoring
Update:
We have implemented a fix.
We are monitoring the result of the fix.
Customers who use the Luno API may still experience delayed balance updates.
Updates to follow
Posted
Oct
19
,
2025
-
18:00
UTC
Update
Update:
Customers may experience delays with balance updates with their Luno wallets.
Our team is working on this as a priority.
Updates to follow
Posted
Oct
19
,
2025
-
12:44
UTC
Identified
We have identified an issue that's causing delayed balance updates for customers who use our API.
Our team is working on this as a priority
Updates to follow.
Posted
Oct
19
,
2025
-
11:21
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed Balance Updates
via . You'll receive .