Delayed deposit allocation for Flutterwave deposits in South Africa
Incident Report for Luno
Resolved
We can confirm that this issue is no longer affecting customers.
Posted Jun 29, 2022 - 18:56 UTC
Investigating
We are noticing some delays in allocating deposited funds to customers' wallets for deposits processed through Flutterwave. Our engineers are investigating the issue.
Posted Jun 29, 2022 - 13:49 UTC