Delayed BTC Sends
Incident Report for
Luno
Resolved
Update:
BTC sends are working as normal as we are no longer seeing delays with sends.
We appreciate your understanding in this matter.
Posted
Jun
04
,
2025
-
02:57
UTC
Identified
We have identified an issue currently causing longer-than-usual processing times when customers are attempting to send BTC cryptocurrency.
No other cryptocurrency sends are affected.
Our team is working on this as a priority.
We apologise for any inconvenience caused
Posted
Jun
04
,
2025
-
00:46
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed BTC Sends
via . You'll receive .