Curve Token (CRV) Is Currently Unavailable
Incident Report for
Luno
Resolved
This issue has now been resolved.
Posted
Jun
26
,
2025
-
00:35
UTC
Investigating
We're currently experiencing an issue that has caused Curve Token (CRV) to become unavailable to Buy/Sell. We are promptly working on resolving this and will further update as soon as possible. We thank you for your patience.
Posted
Jun
25
,
2025
-
23:44
UTC
×
Subscribe to Incident
Subscribe to updates for
Curve Token (CRV) Is Currently Unavailable
via . You'll receive .