Delayed reallocation of funds from canceled orders
Incident Report for Luno
Resolved
This has been resolved and orders are being processed as normal.
Posted Oct 29, 2022 - 10:23 UTC
Investigating
We are currently investigating an issue causing delayed reallocation of funds to wallets from canceled orders.

We are working on this as a priority.
Posted Oct 29, 2022 - 09:52 UTC