Slow balance updates on and errors on the Exchange

Incident Report for Luno

Resolved

We've been stable since our last update, thanks again for your patience.
Posted 13 days ago. Mar 19, 2025 - 14:26 UTC

Update

This has been fully resolved, no further customer impact since 09:15 UTC, we're monitoring for a little longer.

Apologies for the inconvenience this issue has caused.
Posted 13 days ago. Mar 19, 2025 - 11:45 UTC

Monitoring

We're working to resolve the root cause of this incident, balance updates as well as Exchange orders can be placed and executed as normal.
Posted 13 days ago. Mar 19, 2025 - 10:42 UTC

Update

We are continuing to work on a fix for this issue.
Posted 13 days ago. Mar 19, 2025 - 10:11 UTC

Identified

Issue is still being investigated, our balances update in Exchange are also delayed
Posted 13 days ago. Mar 19, 2025 - 10:06 UTC

Investigating

Some customers may see delays between placing orders and seeing those execute successfully.
Our team have already identified the issue and are in the process of working on a fix.

The Exchange and API will have been affected.

Updates to follow.
Posted 13 days ago. Mar 19, 2025 - 08:20 UTC