Degraded Performance
Incident Report for
Luno
Resolved
We have resolved this issue, and there is no longer any degraded performance affecting our platform.
We apologise for any inconvenience caused.
Posted
Mar
19
,
2024
-
19:29
UTC
Investigating
We are currently investigating an issue causing intermittent degraded performance across our platform.
We are working to resolve this as soon as possible and will provide further updates as soon as they are available.
Posted
Mar
19
,
2024
-
18:33
UTC
×
Subscribe to Incident
Subscribe to updates for
Degraded Performance
via . You'll receive .