Voucher Deposits temporarily unavailable in Nigeria
Incident Report for Luno
Resolved
Update:

This issue has been resolved.

Customers should no longer receive any errors when attempting to deposit via voucher.

We appreciate your understanding and patience in this matter.
Posted Feb 03, 2025 - 11:36 UTC
Identified
Update

We have identified an issue that is causing an error for customers when trying to deposit using the voucher option in Nigeria.

Please note: The EFT deposit option is still available for customers.

Unfortunately, this issue is with our payment provider, we are working closely with them to resolve this as soon as possible.
Posted Feb 03, 2025 - 10:45 UTC
Investigating
We are investigating an issue that is causing an error for customers when trying to deposit using the voucher option in Nigeria.

Please note: The EFT deposit option is still available for customers.

We apologize for any inconvenience caused.
Posted Feb 03, 2025 - 10:40 UTC