Delayed express withdrawals in South Africa
Incident Report for Luno
Resolved
Express withdrawals are now being processed as normal.

We apologise for any inconvenience caused.
Posted Sep 14, 2023 - 10:02 UTC
Update
Unfortunately Express ZAR Withdrawals in South Africa are still delayed, we're expecting some feedback from our bank tomorrow. That means requesting an Express Withdrawal will only be processed during the next slot.

You can view withdrawal slots for South Africa on our Help Centre https://www.luno.com/help/en/articles/11000022934

Until this is resolved please make use of normal withdrawals, leaving the Express Withdrawal unticked.

We're sorry about the issues this is causing.
Posted Sep 13, 2023 - 15:56 UTC
Identified
There may be temporary delays with express withdrawals. The bank is urgently working on having this resolved.

We apologise for any inconvenience caused.

We will update you as soon as we have further information.
Posted Sep 13, 2023 - 13:36 UTC