Delayed Withdrawals In Nigeria
Incident Report for Luno
Resolved
This has been resolved and withdrawals are working as expected.
Posted Nov 01, 2022 - 14:31 UTC
Investigating
We are currently experiencing an issue that may be causing temporary delays with Nigerian bank withdrawals.

We are working on this as a priority.
Posted Nov 01, 2022 - 11:08 UTC