Delayed Withdrawals In Nigeria
Incident Report for Luno
Resolved
Our payment provider has resolved the issue, and withdrawals are no longer delayed.

Thank you for your understanding and patience.
Posted Oct 19, 2024 - 05:06 UTC
Identified
Customers may see slower than normal processing times when withdrawing NGN due to an issue with our payment provider.

We appreciate your understanding in this matter.
Posted Oct 18, 2024 - 11:53 UTC