Unable to buy or sell xStocks
Incident Report for
Luno
Resolved
Update:
We are no longer seeing any issues relating to buying or selling Xstocks.
We appreciate your understanding in this matter.
Posted
Nov
19
,
2025
-
06:52
UTC
Identified
We've identified an issue affecting xStocks, which may cause customers to be unable to buy or sell xStocks via Luno.
Our teams are working to fix this as a priority.
Updates to follow.
Posted
Nov
19
,
2025
-
04:12
UTC
×
Subscribe to Incident
Subscribe to updates for
Unable to buy or sell xStocks
via . You'll receive .